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Description 
This document will walk users through the process of using the OpenRoads Designer (ORD) 
2024 Regression Tools to create and refine horizontal alignments based on surveyed points. 
Use the below link to view a video demonstration of these Instructions. 
https://www.youtube.com/watch?v=hAyZHclgJfc 

Export Survey Points 
Note: This section walks you through importing ECCs points from collector into Trimble 

Business Center (TBC) and exporting to CSV file. 

1. Open TBC > New Project > Select correct Template (International Feet Geoid 18 or US 

Survey Feet Geoid 03) 

 

 

https://www.youtube.com/watch?v=hAyZHclgJfc


Regression Tools for Surveyed Centerline 

 

July 10, 2025                                                    BTSD                                                               Page 2 of 32 
 

2. Project Settings > Coordinate System > Local Site > Local Site Settings  
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3. Local Site Settings > Ground Coordinates > Check box for Use ground coordinates > 

Ground scale factor > Input project specific DAF > Select OK at the bottom 

 
4. Drag and drop ECCs JOB file into Plan View window > Keep the existing project 

definition. 

 

 

 

 

 

 



Regression Tools for Surveyed Centerline 

 

July 10, 2025                                                    BTSD                                                               Page 4 of 32 
 

5. Select Export > Custom Tab > select P, N, E, elev, Code 

6. Under Data > Options > Select All 

7. File Name > Select ... > Name file and Map location 

8. Select Export 

 

Import Survey Points 
Note:  This section walks you through importing points from CSV file to a 2D DGN file. 

1. Copy and Paste the NDOT_2D_Seed_Int_Ft.dgn file onto your C drive. Rename the file “[CN] 

Surveyed Centerline.dgn” and open the file. 

2. Open the "OpenRoads Modeling" Workflow. In the Utilities tab, select "Coordinate System". 

 

3. In the Coordinate System window, click "From Library". (second icon from the left) 
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4. The DAF factors are in subfolders arranged by District. Browse to your projects DAF factor. 

Select it and click OK.  

 
 

5. The coordinate system will be set. Close the Coordinate System window. 

 
 

6. Next, in the Geometry tab, under the “Import/Export” drop-down, click "Import 

Horizontal Points from Ascii File". 
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7. The cursor will prompt you to select an element for Station Offset method. We will not 

use this method, so Right-click to reset. 

 

8. Change the “Files of type:” drop-down to All Files. Browse to the “[CN] Centerline 

Points” csv file that was exported from Trimble. Select the file and click “Done”.   

 

9. The Import Horizontal Points from ASCII File window will appear. To the right of “Wizard 

Settings File”, click the browse button (3 dots).  

 

 

 

 

 



Regression Tools for Surveyed Centerline 

 

July 10, 2025                                                    BTSD                                                               Page 7 of 32 
 

10. Browse to file “NDOT_Dist_ECC_Import.xml” located in the folder 

“C:\ProgramData\Bentley\OpenRoads Designer 

2024.00\Configuration\WorkSpaces\NDOT Standards 2023.10\Standards\data”, click 

Add, and then click OK. 

 

11. Next, under Feature Definition, use the drop-down to set the Feature Definition to 

"Construction Point". 

 

12. Leave the Name blank. 
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13. Click Import. 

 

14. After the import has processed, close the Import window. 

 

15. The points will be drawn in to the drawing window. Click “Fit View” to see them all.  
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User Preference Settings 
Note: These settings only need to be set once. They will only need to be reset if user 

preferences are cleared. 

1. Go to File > Settings > User > Preferences.  

 

2. Navigate to View Options Civil > Regression Settings.  

3. Set the Unacceptable Slew Value to 0.5 for horizontal regression. This value determines 

when the display color changes (e.g., orange below the value, red above). 

4. Set the Exaggeration to 100. This will make the display of the regression line easier to 

understand.  

5. Set “Show Point Name” to True. This will help identify what points you are looking at 

when running the regression analysis. 
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Create the Regression Line 
1. Select All ECC points using the Element Selection dialog. 

 

2. In the OpenRoads Modeling workflow, under the Geometry tab, find the Regression 

tools section. Under the Create Regression Line dropdown, select Regression Line from 

Points. 

        

3. Click in the Drawing to accept the selected points. 

 

4. The next prompt asks to Locate the Starting Point for Regression. The first point will be 

at the beginning reference post for the project. This is usually the west-most or south-

most point of the alignment.  

 

5. Next, it prompts you to select a second point that will define the Regression Direction. 

This is the same as the direction of the Stationing for the alignment.  

 

 



Regression Tools for Surveyed Centerline 

 

July 10, 2025                                                    BTSD                                                               Page 11 of 32 
 

6. In the Create Regression Line From Points dialog, match the setting to the image:   

o Min/Max Distance Tolerance: Controls the 

allowable distance along the alignment between the 

regression alignment and the original survey points 

(distance front/behind the current point being 

analyzed). Set the minimum to 1 and the maximum 

to 300. 

o Min/Max Deviation: Controls how much the 

generated regression line can deviate laterally 

(left/right) from the surveyed points. This helps 

smooth the alignment while staying close to the 

data. Set the miminum to 0 and the maximum to 10. 

o Unacceptable Slew Left/Right: This setting will help 

analyze when the regression line is beyond a certain 

distance. Set this to 0.5 for both. 

o Maximum Lift/Lower: This setting is used for vertical 

regression and is not being utilized for our purposes. 

Set both to 100.  

o Complex Feature Definition: This setting defines the 

feature definition of the Alignment that will be 

created with the regression tools and eventually 

used as the project centerline. Change the Feature 

Definition to Alignment/Mainline. Change the Name 

to the control number and highway number with 

formatting “[ControlNo.][HwyNo.]”. 

o Feature: This setting defines the feature definition of 

the regression line that visually displays the slews. 

Change the Feature Definition to Alignment/Survey. 

The name can be left as the default name.  
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7. In the Drawing window, click through all of the prompts (4 clicks). The regression line 

will be drawn between the points. Check through and confirm that the regression line is 

drawn all the way to the last surveyed point. If it is not, then press undo (Ctrl+Z) to undo 

its placement and try placing it again with higher values put in for the Maximum 

Distance Tolerance and Maximum Deviation.  

 

8. **OPTIONAL** In the Geometry tab, select Single Offset Entire Element. Define an 

offset of 50. Click on the Regression line and place an offset line on both sides of the 

alignment. This line will visually represent the maximum allowable slew distance. 

 

9. Next, Generate the Curvature Diagram:  

a. Right-click and hold anywhere in the drawing. Click View Control > 2 Views 

Plan/Profile. This will create 2 drawing views. 

 

b. A window will pop up to open a dynamic profile view. Click Cancel.  
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c. Next, in the Regression tools, click Curvature Diagram. 

 

d. Select the Regression Line in the top view. Then click in the bottom view to place 

the diagram. 

 

e. Interpret Diagram:  

▪ The Horizontal Axis represents Stationing along your alignment. 

▪ The Vertical Axis represents the deflection of each point relative to its 

neighboring points. 

▪ Points closer to the horizontal axis have low deflection, indicating 

Tangents. Points farther away from the horizontal axis have higher 

deflection, indicating a Curve. 

▪ Anything below the axis (negative deflection) indicates a Left-hand curve. 

Anything above the axis (positive deflection) indicates a Right-hand 

curve. 

▪ A well-defined curve in the survey data should look relatively smooth in 

the diagram, somewhat resembling a curve shape. 

▪ Jagged points or unexpected large jumps in deflection can indicate 

potential issues with the survey data or areas that will be difficult to fit 

with standard geometry (like the problematic curve in the transcript 

example). Look for points that seem out of place relative to the overall 

trend. 

▪ Use Ctrl + Mouse Wheel to adjust vertical exaggeration, which can help 

visualize subtle changes or flatten noisy data. 
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Alignment Creation Process Outline 
The following instructions will use a combination of the Regression tools and Horizontal Geometry tools 

to create the alignment as a single complex element. These instructions will show how to use the tools, 

but the alignment creation will not always be straight forward, depending on the complexity. Here is a 

quick rundown of the process of creating the alignment: 

1. Run the Quick Horizontal Regression tool (page 15) on the whole alignment with Tolerance set 

to 0.5. 

2. Check the tangents and curves for slew values above 0.5 or gaps.  

a. Scenario 1: If all slew values are within 0.5 and there are no gaps, the alignment was 

created successfully and you may move on to the “Finalize Alignment” section in these 

instructions (page 27). 

b. Scenario 2: If there are slew values above 0.5 within tangent sections only, use the 

Insert Vertex tool (page 16)  to create an additional PI until the slew is within 0.5. The 

alignment is then finished and you may move on to the “Finalize Alignment” section in 

these instructions (page 27).  

c. Scenario 3: If there are slew values above 0.5 within curves or gaps in the alignment, 

mark the areas where it is off using a circle or line and delete the alignment. Move on to 

step 3. 

3. Run the Quick Horizontal Regression tool (page 15) on each tangent section of the alignment, 

starting and stopping 2 ECC points short of PC or PT, with the tolerance set to 0.5.  

a. Use the “Insert Vertex” tool (page 16) to create additional PI’s if there are slews above 

0.5 within the tangent sections. 

4. Run the Quick Horizontal Regression tool (page 15) on each curve, starting and stopping 1 point 

within the PC/PT of the curve, with the tolerance set to 1.0. 

a. If the slews along the curve are larger than 0.5, press undo and try again with a higher 

tolerance (1.5, 2, etc.).   

i. If this yields a line with slews less than 0.5, skip to step 7.  

ii. If a line with slews less than 0.5 cannot be drawn, press undo (Ctrl+Z) to remove 

the line and move to step 5. 

5. Run the Single Horizontal Regression tool (page 18) on the first curve.  

a. Start by running a single line across the whole curve, from PC to PT. If this creates a 

regression line with slew values all less than 0.5, you may move on to step 6. If not, 

press undo (Ctrl+Z) to remove the placement of that line. 

b. Create two or more curves within the single curve. Space them out at least 3 ECC points 

apart. Use the Curvature Diagram to help determine what points to include or exclude.  

6. Use the Geometry Connector tool (page 19) to connect 2 curve elements within the same 

Alignment curve. 

a. If the Geometry Connect cannot solve, close the Geometry Connector window and press 

undo (Ctrl+Z) to remove the lines drawn in step 5, and repeat step 5 with curves placed 

in different locations or with more curves. 

7. Use the Line To Element tool (page 24) to draw a line tangent from curve element to the line 

element (this line will NOT get added to the complex element). 

8. Manually move the end of the curve to the line drawn in step 7 to remove the gap or overlap. 

a. Remember to uncheck the “Sweep Angle” box. 
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9. Delete the line drawn in step 7. 

10. Use the Single Horizontal Regression tool (page 18) to draw a line between the tangent and the 

curve (this line will get added to the complex element). 

11. Manually move the line drawn in step 10 to connect to the tangent element on one end and the 

curve element on the other end.  

12. Repeat steps 4 through 11 until a single alignment has been created without any gaps and all 

slews are within 0.5. Move on to the “Finalize Alignment” section in these instructions (page 27).   

Regression and Geometry Tools 
1. Quick Horizontal Regression tool: 

a. In the Geometry tab in the Regression Tools drop-down, select the Quick 

Horizontal Regression tool. 

 

b. Set the Tolerance to 0.5. This defines an offset the 

software tries to achieve for its best-fit alignment 

through the surveyed points. It is not a guarantee of 

maximum slew. It's a target value less than or equal 

to which the tool attempts to fit the geometry. 

Experiment with this value; smaller values aim for 

higher precision but might fail or produce gaps if 

data varies too much. Sometimes a slightly higher 

tolerance gives smoother, more usable results even 

if individual slews are larger. 

c. Leave the “Include Spirals” and “Apply De-Kinking 

Radius” boxes unchecked. 

d. Set both Unacceptable Slew values to 0.5. 

e. The Feature definition does not need to be set. The 

tool will use the feature definition settings defined 

when creating the regression line.  
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f. Then, in the plan view window (top window), select the Regression Line. 

g. Define the start and end points along the regression line. Press Alt to snap to the 

beginning of the regression line, click, and then press Alt again to snap to the end 

of the regression line and click again. 

h. Click to accept the 0.5 tolerance.  

i. The software will create an alignment (green line) that includes tangents and 

curves. The regression line (white line) will move away from the surveyed points 

at a distance equal to the space between the surveyed point and the green line 

multiplied by 100. It will try to stay within the tolerance, but may not be able to 

in some areas. 

j. Select the Regression line and zoom in. You’ll be able to visually see what the 

slew values are. Any slew value that is greater than 0.5 will appear red. 

 

2. Insert Vertex tool: 

a. In the Drawing window, under the top-right drop-down in the Modify section, 

select Insert Vertex. 

 

b. Click on the line segment in the approximate location where you want to place 

the PI.          

**NOTE** This tool only works to place a PI on a line element. This tool will not 

work on a curve element. 
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c. The original line will turn purple and the green line will follow your cursor.  

 

d. The Line will be placed and the White regression line will adjust to the new 

offsets. Check that the slew values for both line segments before an after the 

new PI are less than 0.5. If adjustments still need to be made, click on the 

alignment and find the handles. The dot in the center represents end/beginning 

of the two line segments. Click on this dot and move your cursor to the desired 

location. This will move the PI.  
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3. Single Horizontal Regression:  

a. Select the Single Horizontal Regression tool. 

 

b. Select the Regression Line in the Curvature Diagram (bottom window). 

 

c. In the Horizontal Geometry window, set the Geometry drop-down to Automatic. 

This can be set as Line or Arc if desired. 

d. Set the Unacceptable Slew values to 0.5 

e. The Feature definition does not need to be set. The tool will use the feature 

definition settings defined when creating the regression line. 
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f. Then, in the Curvature Diagram, select a place on the window that is before the 

first survey point used. Then select a second point that is after the last survey 

point used. Then move your cursor up or down to create a rectangle big enough 

that includes all survey points between the first and last survey points. The 

survey points will turn orange. You will also see a preview of the slews in the 

plan view (top window). 

 

g. Click again to accept the placement of the geometry line. 

 

h. Review the slew values. If there are values greater than 0.5, then click Undo and 

try creating the same line with one less point at the end or beginning. You may 

need to create several curve elements within a single alignment curve and then 

connect the segments through the next method. 

 

4. Geometry Connector Tool: 

a. In the Geometry tab, in the Complex Geometry drop-down, click Geometry 

Connector. 
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b. The Geometry Connector window will appear. First, we need to define the Begin 

and End element. At the top right of the window, click Select Element. 

 

c. Select the first segment from the alignment. Click on the segment a second time 

to accept the selection. 

 

d. The Geometry Connector window will populate with that element’s attributes. 

Next, in the bottom right of the window, click Select Element. 
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e. Click on the second segment from the alignment. Click on the segment a second 

time to accept the selection. 

 

f. The End Element will populate with the element information. Select the heading 

of the first column to select all elements between the begin and end element 

and press delete (5th icon from the top on the right side). 

 

g. Uncheck the “Free” box for the End Element. Check the “Replace” box for both 

the Begin and End elements. Toggle on the “Rules” toggle (third icon from the 

right, top left side of the window).  
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h. Next, we will add elements between the begin and end elements. Use the Drop-

down in the Type column to select either a line or a curve (we do not allow spiral 

curves). Define an approximate length for the line. If placing an Arc, define and 

approximate length and radius, and click the toggle in the Hand column to switch 

the direction of the arc. In the plan view, it will display a preview of the elements 

placed. Try to define lengths and radii that makes the preview appear close to 

the solution.  

 

i. The bottom left needs show “Ready to Compute”. If it does not, then 

uncheck/check “Free” boxes within the window until the proper number of free 

and fixed elements are defined. Once it’s showing “Ready to Compute”, click 

Compute. 
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j. You may see a computation error similar to the one below. If this occurs, try 

using the Up or Down arrows on the right side of the window to change the 

order of the elements. 

 

 

k. If the computation is successful, then the line in the lines connecting the begin 

and end element will appear in the drawing window. Click Apply.  

 

l. Close the Geometry Connector window. The alignment with the connected 

elements will be drawn and the Regression Line will update. Check the slews for 

the new elements drawn. If the slews are larger than 0.5, press undo (Ctrl+Z) to 

remove the connected elements. Manipulate the begin/end elements and then 

try the geometry connector again. 
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5. Line To Element Tool:  

a. In the Geometry Tab, under the Lines drop-down, navigate to Line To Element > 

Line To Element.  

 

b. Look at the message next to your cursor. It should read as shown below. If it 

does not, press “Alt” on your keyboard. 

 

c. Click the beginning/end of the curve element. 

 

d. Next, set the Offset to 0 and click to accept. 
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e. Then, set the skew to 0. Move your cursor and a line will appear between your 

cursor and the curve.  

 

**NOTE** If the line appears in the wrong direction, then in the Line To Element  

 window, check the Solution checkbox and change the solution drop-down to 2. Then  

 move your cursor to the drawing window and the line will appear the correct direction. 

 

f. Snap to the endpoint of the tangent line and click to place the line. 
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g. We will not use the Trim/Extend setting. Click again to accept the placement of 

the line. 

 

h. Zoom in to the location where the line runs tangent into the curve. There will 

either be a gap or an overlap between the line and the curve. Click on the curve 

and locate the handle for its endpoint.  

 

i. Click on the Dot. Then, the Arc Between Points window will appear. Uncheck the 

“Sweep Angle” check box and ensure that no other checkboxes are checked. 

 

j. Snap to the Line and click to place. The curve will now connect to the line with 

now gap or overlap. 
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Finalize Alignment 
1. Define Stationing: 

o In the Geometry tab, under the Modify drop-down, select Start Station. 

 

o Click the Alignment.  

 

o Set the Start Distance to the beginning of the alignment (It will display 0+00, you 

can hit 0 on your keyboard and press enter to snap to it). 

 

o Type in the beginning station of the alignment. The stationing should at 

minimum start at 100+00.  

 

o Click again to accept. 
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2. Reporting:  

o In the Regression Tools drop-down, click Regression Report. 

 

o Click the Alignment. 

 

o Locate the start station. Click Alt on your keyboard to snap to the beginning of 

the alignment, then click once. 

 

o Locate the end station. Click Alt on your keyboard to snap to the end of the 

alignment, then click once. 
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o Set the Interval to 0. Click once. 

 

o Set the “Include Event Points” to None. Click once. 

 

o The Bentley Civil Report Browser will appear. On the left, click on the report 

“NDOT Regression/NDOT Regression Review”. 

o The report will display 2 different reports.  

1. The first section is the Regression Review. On the right, the column 

“Slew” shows the distance between the surveyed points to the 

Alignment. Any Slew value that is greater than 0.5 will highlight red.  

2. The second section checks the integrity of the Alignment. The column 

“Angular Difference (End to Next)” shows the deflections of the PI’s, PC’s, 

PT’s, and other points along the alignment. This value will highlight red if 

the line approaching a PC or beyond a PT has a deflection other than 

zero. It will also highlight red if it shows a deflection between two 

tangent sections that is greater than 0°30’.  

o Once the report is reviewed and accepted, click File > Print. 
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o Change the Printer to Microsoft Print to PDF. Click Print. 

 

o Browse to the desired location on your C drive. Change the File Name to “[CN] 

Regression Review”. Click Save. 
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3. Exporting: 

o In the Geometry tab, under the Import/Export drop-down, click Export 

Geometry. 

 

o Change the version to 2.0. Uncheck the Only Active Profiles box. Set the Export 

Type to LandXML.  

 

o Click once to accept the export type. 

o Next, select the alignment. Then, right-click to accept. 

 

o Click through the prompts (two clicks) to accept the settings. 
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o The document name will match the name of the alignment by default. Browse to 

the desired location on your C drive and click Save. 

 

 

 


